Mikrotik – Script para controle de ACK

Share Button

Esse Script controla o ACK de todas as interfaces Wireless, os ACKs devem ser menores que a variavel $ack, caso contrario o script derruba a conexão do cliente. Porem a queda é tão rapida que o cliente não percebe, e claro normalmente melhora o ACK do cliente..

1
2
3
4
5
6
7
8
9
10
11
12
13
:global ack 91; :global mac ; :global ack2; :global confirm; :global cliente;
:log info "EXECUTANDO SCRIPT DE ACK"
:foreach i in=[/interface wireless registration-table find] do={
:set confirm ([/interface wireless registration-table get $i ack-timeout] > $ack);
:if ($confirm=true) do={
:set mac [/interface wireless registration-table get $i mac-address];
:set cliente [/interface wireless registration-table find mac-address=$mac];
:set ack2 [/interface wireless registration-table get $i ack-timeout];
:log info "Desconectado cliente $mac o ack dele erra $ack2 "
/interface wireless registration-table remove $cliente;
};
 
};

Uma ideia sobre “Mikrotik – Script para controle de ACK

Deixe uma resposta