CONFIGURANDO SWITCHS QUANTA (FASTPATH)

Share Button

HP, English Title: Configuring quanta switchs

Neste post irei demostrar as principais configurações de switchs QUANTA com firmware FASTPATH

A primeira diferença entre o switch quanta e a maioria dos switchs do mercado é que nessa versão de firmware FASTPATH algumas das configurações básicas são feitas em modo enable e não em modo configure como de costume.

Vamos ao que interessa.

Configurando o name do router

set prompt "SW-01-LOCAL"

Setando o password de enable

enable passwd encrypted minhasenha

Configurando IP de gerencia
Iremos configurar o IP 192.168.0.10/24 com o gateway 192.168.0.1 na vlan de gerencia 10

network protocol none
network parms 192.168.0.10 255.255.255.0 192.168.0.1
network mgmt_vlan 10

Criando Vlans

vlan database
vlan 10,20,30

Nomeando as Vlans

vlan name 10 "VLAN-10" 
vlan name 20 "VLAN-20" 
vlan name 30 "VLAN-30" 

Configurando snmp
Obs. Note que daqui para frente devemos estar em modo configure para realizar as próximas configurações

snmp-server sysname "SW-01-LOCAL"
snmp-server location "MEU-LOCAL"
snmp-server contact "MEU_CONTATO"

Setando usuário e senha para acesso telnet e WEB

users passwd "admin" encrypted minhasenha

Desabilitando o spanning-tree de todo o switch

no spanning-tree

Configurando uma porta como acesss da vlan 10 (untagged)

interface 0/1
description 'DESCRIÇÃO'
no spanning-tree port mode
vlan pvid 10
vlan participation include 10
exit 

Configurando uma porta para repassar a VLAN (Trunk / General) para permitir a passagem das vlans 10 e 20

interface 0/1
description 'DESCRIÇÃO'
no spanning-tree port mode
vlan acceptframe vlanonly
vlan participation include 10,20
vlan tagging 10,20
exit 

Configurando port-channel

Criando o port channel

port-channel system priority 1
port-channel PORT-CHANNEL1

Checando qual a interface do port channel

show port-channel all

                                                                         
Log.       Channel            Adm.      Mbr    Device/       Port      Port
Intf        Name        Link  Mode Type Ports  Timeout       Speed     Active
------ --------------- ------ ---- ---- ------ ------------- --------- -------
3/1    PORT-CHANNEL1     Up     En.  Dyn. 0/1    actor/long    Auto      True   
                                               partner/long  
                                        0/2    actor/long    Auto      true  
                                               partner/long  

Neste caso como é o primeiro port channel o nome da interface para ele é 3/1 caso existam mais quem um port-channel ele terá o nome das próximas interfaces, como 3/2..3/3…..

Setando o tipo de loadbalance
Esse switch como é L2 e L3 possui vária formas de ser configurado o LB como:
1 Src MAC, VLAN, EType, incoming port
2 Dest MAC, VLAN, EType, incoming port
3 Src/Dest MAC, VLAN, EType, incoming port
4 Src IP and Src TCP/UDP Port fields
5 Dest IP and Dest TCP/UDP Port fields
6 Src/Dest IP and TCP/UDP Port fields

Nesse caso configurarei com a opção 6 – Src/Dest IP and TCP/UDP Port fields

port-channel load-balance 6 3/1

Adicionando interfaces ao port-channel

interface 0/1
addport 3/1
exit 
interface 0/2
addport 3/1
exit 

AirOS Configurando vários SSIDs no mesmo equipamento

Share Button

English title: AirOs (ubiquiti) Configuring multiple SSIDs in the same device

A algum tempo atras publiquei um artigo AQUI mostrando como configurar vários SSIDs em um equipamento rodando AirOS da Ubiquiti. Porem após a versão 5 do AirOS não é mais possível criar esse SSIDs da mesma maneira, sendo assim irei demostrar uma maneira diferente porem mais simples para isso.

Inicialmente editaremos o arquivo /etc/persistent/rc.poststart

#vi /etc/persistent/rc.poststart

Insira as seguintes linhas

ssid="YOUR-SSID";
wlanconfig ath create wlandev wifi0 wlanmode ap
iwconfig ath1 essid "$ssid"
brctl addif br0 ath1
ifconfig ath1 up

Na variável ssid deve ser configurada conforme o SSID a ser configurado.

Após a configuração é necessário salvar a configuração para que após o boot do dispositivo as configurações funcionem.

Use o comando.

#cfgmtd -w -p /etc/;

Pronto agora é necessário um reboot no equipamento.

#reboot

Bloqueando FACEBOOK e outras redes sociais no RouterOS – Mikrotik

Share Button

O bloqueio apesar de simples pode ser usando para qualquer site, já que é feito usado uma determinada string e portas de conexão.

O que fazemos é criar um regra de Layer7, contendo a string (REGEXP) com o nome que desejamos bloquear.

Após criar as regra de Layer7, crie uma regra de FORWARD bloqueando todos os pacotes que satisfazerem essa L7 nas portas 80(http) e 443(https).

Caso queira bloquear o próprio facebook, basta copiar e colar as regras no terminal do Mikrotik, lembrando que pode ser alterado a string (regexp) para “twitter” por exemplo.

1
/ip firewall layer7-protocol add name=facebook regexp=facebook
1
2
/ip firewall filter add action=drop chain=forward comment="facebook" \
disabled=no dst-port=80,443 layer7-protocol=facebook protocol=tcp

Ubiquiti – Checando sinal de equipamentos conectados via SSH

Share Button
Os produtos ubiquiti quando estão em modo AcessPoint ou AcessPointWDS, não é possível verificar os sinal de todos os stations conectados com o comando iwconfig, pois esse comando só verifica o sinal de apenas um station.
Fiz teste a partir da versão 5.2 do AirOS, e funciona perfeitamente.
Seguem a maneira mais fácil que encontrei como verificar o sinal dos clientes com o comando WSTALIST.
;
;
#SEGUE O HELP DO COMANDO.
XM.v5.2.1# wstalist -h
Usage: wstalist [options]
-i <interface> wireless interface name
-a <mac address> ap/client mac address
-h display this message and exit
.
.
#COM O SEGUINTE COMANDO PODEMOS VERIFICAR TODOS OS CLIENTE DE UMA DETERMINADA INTERFACE WIRELESS.
.
.
XM.v5.2.1# wstalist -i ath0
[
{
“mac”: “00:15:6D:DC:C1:2E”,
“name” : “ROCKET”,
“lastip” : “10.0.0.1”,
“associd” : 1,
“apwds” : 0,
“tx” : 162,
“rx” : 90,
“signal” : -60,
“ccq” : 60,
“idle” : 0,
“uptime” : 4293654134,
“ack” : 54,
“distance” : 4200,
“txpower” : 54,
“noisefloor” : -91,
“airmax” : {
“priority” : 3,
“quality” : 71,
“capacity” : 36 },
“stats” : {
“rx_data” : 1638035927,
“rx_bytes” : 277979729056,
“rx_pps” : 1439,
“tx_data” : 2021186544,
“tx_bytes” : 1889608191118,
“tx_pps” : 1998 },
“rates” : [ “MCS0”, “MCS1”, “MCS2”, “MCS3”, “MCS4”, “MCS5”, “MCS6”, “MCS7”, “MCS8”, “MCS9”, “MCS10”, “MCS11”, “MCS12”, “MCS13”, “MCS14”, “MCS15” ],
“signals” : [ 0, 0, 0, -64, 0, 0, 0, 0, 0, 0, 0, -63, -65, -65, 0, 0 ]
}
]
#COM ESTE OUTRO COMANDO É POSSÍVEL PASSAR O MAC DO CLIENTE, PARA QUE POSSAMOS VERIFICAR SOMENTE OS ATRIBUTOS REFERENTES A A UM DETERMINADO CLIENTE.
.
.
XM.v5.2.1# wstalist -a 00:15:6D:DC:C1:2E
[
{
“mac”: “00:15:6D:DC:C1:2E”,
“name” : “ROCKET”,
“lastip” : “10.0.0.1”,
“associd” : 1,
“apwds” : 0,
“tx” : 180,
“rx” : 180,
“signal” : -61,
“ccq” : 58,
“idle” : 0,
“uptime” : 4293654146,
“ack” : 54,
“distance” : 4200,
“txpower” : 54,
“noisefloor” : -91,
“airmax” : {
“priority” : 3,
“quality” : 76,
“capacity” : 31 },
“stats” : {
“rx_data” : 1638053187,
“rx_bytes” : 277982545675,
“rx_pps” : 1428,
“tx_data” : 2021208906,
“tx_bytes” : 1889631584968,
“tx_pps” : 1830 },
“rates” : [ “MCS0”, “MCS1”, “MCS2”, “MCS3”, “MCS4”, “MCS5”, “MCS6”, “MCS7”, “MCS8”, “MCS9”, “MCS10”, “MCS11”, “MCS12”, “MCS13”, “MCS14”, “MCS15” ],
“signals” : [ 0, 0, 0, -64, -64, 0, 0, 0, 0, 0, 0, -63, -64, -65, 0, 0 ]
}
]
XM.v5.2.1# exit

;